This project is read-only.

function naming conventions

Feb 4, 2009 at 5:01 AM
should we standardise on some naming conventions (and also a global variable container?)
should we use a noun prefix?
expand-alias be Expand-ISEAlias and invoke-caretline be invoke-ISEcaretLine ?

thoughts?
Feb 4, 2009 at 12:50 PM
Yes, ISE as a noun prefix sounds like a good idea. As far as I understand this is still the only real way "namespaces" work in PowerShell.
Feb 5, 2009 at 11:59 AM
Yes, this seems a good idea. I propose to follow this pattern in a stringent way, even for the nonpublic functions of modules.